1.5.4 admin 的错误!!!

Zen Cart的安装、设置、升级讨论和使用技巧交流

版主: shaning

1.5.4 admin 的错误!!!

帖子sunrise » 2015-01-07 11:00

[07-Jan-2015 02:49:52] PHP Parse error: syntax error, unexpected T_STATIC in /home/admin、includes/classes/class.admin.zcObserverLogEventListener.php on line 118

请问如何解决? 谢谢!
每月只需3.45 USD ( 24RMB) 无限空间;所有TM怪兽模板500元!!!
sunrise
高级会员
高级会员
 
帖子: 180
注册: 2007-12-27 10:23

Re: 1.5.4 admin 的错误!!!

帖子sunrise » 2015-01-07 12:34

NOTE: This is ONLY necessary if you're using PHP 5.2.x

If your server is still using PHP version 5.2.x (which is VERY OLD and now officially obsolete since 2011) and you try to use ZC v1.5.4 you may encounter an error akin to the following when trying to access the Admin area:

Error:
PHP Parse error: syntax error, unexpected T_STATIC in /admin/includes/classes/class.admin.zcObserverLogEventListener.php on line 118

Fix:
On line 118 of /admin/includes/classes/class.admin.zcObserverLogEventListener, change:
Code:
$levels = static::$levels;
to:
Code:
$levels = self::$levels;
Remember: PHP 5.2.x is obsolete and officially no longer supported by anybody. You should be upgrading your server's PHP version ASAP.
每月只需3.45 USD ( 24RMB) 无限空间;所有TM怪兽模板500元!!!
sunrise
高级会员
高级会员
 
帖子: 180
注册: 2007-12-27 10:23

Re: 1.5.4 admin 的错误!!!

帖子sy7600gr » 2015-01-10 21:47

把你的PHP版本升级一下
sy7600gr
新手上路
新手上路
 
帖子: 12
注册: 2013-08-18 17:01
QQ 帐号: 309863923

Re: 1.5.4 admin 的错误!!!

帖子li-he-qi » 2015-01-11 11:59

撸主在二楼给出了答案, 给下中文的

错误是由于PHP版本是5.2.x (从2011年起5.2.X官方已经停止支持了), 如果你用ZC1.5.4, 会遇到以下错误:
代码: 全选
PHP Parse error: syntax error, unexpected T_STATIC in /admin/includes/classes/class.admin.zcObserverLogEventListener.php on line 118


修正方法:
在/admin/includes/classes/class.admin.zcObserverLogEventListener文件中约118行, 找到:
代码: 全选
$levels = static::$levels;

改成:
代码: 全选
$levels = self::$levels;


建议所有使用PHP5.2.X的用户立即升级
li-he-qi
VIP会员
VIP会员
 
帖子: 544
注册: 2010-09-22 22:47

Re: 1.5.4 admin 的错误!!!

帖子leogn » 2015-01-15 22:02

改了,可以登录进去了.但是只能看到语言切换的,下面的菜单都看不到,咋回事呢?
leogn
 
帖子: 3
注册: 2012-11-07 16:17

Re: 1.5.4 admin 的错误!!!

帖子Jack » 2015-01-16 3:12

修改的代码有误,看看 /logs 目录中的日志
Zen Cart - 让每个人拥有自己生意的梦想成真
加入Zen Cart地图 | 恕不回复站内短信提问 | QQ: 3171061
头像
Jack
论坛版主
论坛版主
 
帖子: 12265
注册: 2004-12-16 10:04

Re: 1.5.4 admin 的错误!!!

帖子huayuhobby » 2015-08-08 11:52

我的是 PHP5.4 哦,怎么也是不能登录后台呢 ?
huayuhobby
 
帖子: 4
注册: 2009-06-10 23:05

Re: 1.5.4 admin 的错误!!!

帖子feihcceo » 2016-04-29 17:05

1.5.4中文插件版,安装完后,后台进不去,啥办?
WARNING: An Error occurred, please refresh the page and try again. Fatal error: 1101:BLOB/TEXT column 'logmessage' can't have a default value :: ALTER TABLE admin_activity_log ADD COLUMN logmessage mediumtext NOT NULL default '' ==> (as called by) D:\wwwroot\030x\admin\includes\classes\class.admin.zcObserverLogWriterDatabase.php on line 90 <== in D:\wwwroot\030x\includes\classes\db\mysql\query_factory.php on line 155
feihcceo
新手上路
新手上路
 
帖子: 5
注册: 2016-04-26 18:21

Re: 1.5.4 admin 的错误!!!

帖子lxhua88 » 2016-10-10 20:08

我同样问题,未解决,请高手?
[color=#40BFFF][size=150][b]在学习中成长,请大家多多指导,
[url=http://chinaorganicnet.com/]中国有机网[/url] http://chinaorganicnet.com[/b][/size][/color]
头像
lxhua88
高级会员
高级会员
 
帖子: 235
注册: 2008-01-25 8:55
地址: 云南昆明
QQ 帐号: 372450706


回到 安装设置



在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客

cron